Draw masked material on HUD is not properly masked

Trying to draw a masked circular progress bar on my HUD, and for some reason the mask isn’t working properly, as it is showing up in game as a white square. Any ideas?


HUD blueprint:


In-game result:


Looks ok at a glance. Are you sure this is applied and the shaders are not compiling?

If that’s a yes, you could play with the Opacity Clip Mask Value - first pic: advanced panel just under Blend Mode

If you change the colour, do you actually see it in PIE?

Not sure what to say. Judging by the setup it should be fine as is. Not 100% certain about the values but that should not matter much here.

OK, I’ve thrown this into the material:


Which produces the aliased result above. But it does work. The only difference is that I’m on 4.25 and you’re 1 version behind. I can’t say why this would matter, though. It’s a pretty simple mask and I’ve worked with the HUD class extensively in the past. Pretty odd.

You can always try using a widget instead.

Hey thanks for your help. Everything has been applied. Tried moving the opacity clip value up and down but no dice. Changing the color does result in a change in-game.