Drag & drop problems (UMG)

Hi.

I have three tasks which I can’t solve with current drag&drop in 4.5:

  1. When I’m creating default visual (on drag event) it spawns in left upper corner of dragabble object. So, it snaps not under the cursor, but with some shift accordingly. How to place it right under cursor ?

  2. Default visual (widget) rendering is horrible: image should be trasnparent. But instead it’s just black in transparent space. Plus image have been some sort of noised and blured.

18502-defvis.png

And that’s how this widget actually looks like:

18503-defshould.png

Don’t worry about number in center. It was removed by logic of construction.

  1. Is there some sort of “begin on drag over event” and “end on drag event” ? I need to do some stuff with dropable widget right after draged object leaved this dropable widget local space.

Hello Alanir,

I would be more than happy to assist you but first I will need some additional information.

Quick questions:

  1. How are your materials set up that you are using for the drag and drop?
  2. Can you send a picture of your material blueprint as well as a picture of your UMG setup?
  3. What type of file are you using to import the image?

Hi Rudy,

  1. I don’t think problem in materials, because regular text box (No name, Empty - captions) have same issues. Background image (orange part) have such material:

White refresh icon - just regular texture in png format:

18833-refresh_icon.png

Both are composed in userwidget, which I creating and using for default visual.

  1. Picutre of UMG setup? What did you mean by setup ?
  2. PNG format. Solid color picture with alpha chanel as profile. You can check refresh_icon.png which attached to comment.

Hello Alanir,

I see that the file type that you are using for your sample texture in the material editor is a PNG. Could you try replacing that with a 32 bit TGA version of your current texture sample and let me know if this makes a difference?

As I already said, file format doesn’t matter. Look at the textbox UMG elements. I’ve just created new widget with border and image in it. Image in TGA format. I’ve got same black borders and no transperancy.

Hello Alanir,

I have a couple more questions for you. I am still unable to reproduce this issue.

  1. Can you reproduce this issue on a clean project?

  2. If you can does this happen with all assets that you try?

  1. Yes. Clean project with starter content.
  2. Did you mean all textures?
    I’ve created a new widget which should be a default visual:

Image for this widget:

19491-test2.png

Settings of import for this image:

How I’m creating default visual, named drag:

And that’s the result (black squared image - default visual of current drag operation):

Any suggestions?

Hello Alanir,

I am still unable to reproduce this issue. Could you provide screen shots of all the blueprints that you are using to produce this problem? This will help eliminate any differences we have in the way we have our drag and drop systems set up.

Hello Alanir,

After posting earlier I gave it another go and was able to reproduce this issue that you are experiencing. I then filled out a report (UE-5016) and sent it to the developers. Thank you for the time and information that lead to the detection and cataloging of this problem. I will provide updates with an pertinent information as it becomes available.

Got the exact same problem, the drag operation seems to automatically fill the visual with a black background. I first tested just the Texture itself, no distortions but the transparent parts are just black. When I tried with a Material, but that had even more problems because it was on the upper left corner of a small black box and I couldnt fix the scaling or the translucency. Drag Visuals seem to only take things that are directly after the root of a widget so no kind of wrapping worked for me!

Hello Rudy.

Thank you!

I also have this issue as i mentioned on the Drag & Drop forum thread. The image is always squared and without alpha. If i try to set the Default Drag Visual to a widget i created nothing appears, i have to set to an image widget for it to show like mentioned before.

Apparently you can’t use on the Default Drag Visual a widget that has a canvas as the root, if i just put an image it works ok except for the alpha.

Are there any news on this? I am experiencing the same issue, if there is a solution or workaround, it would be nice to know :slight_smile:

Hello gormed,

I have recently been able to reproduce this issue. There has been no new and pertinent information about this issue. However, I do have an example of how to achieve a workaround for this issue.

You can find it here: UMG Drag & Drop (UE 4.6) - UI - Unreal Engine Forums

This example includes the a downloadable version of the widget that is shown in the pictures. I hope this helps.

Make it a great day