Drag and drop or right click does not add time to level blue print

This morning I started my project, but when I try to drag and drop an item from my level to my level blueprint nothing happen and with the item selected I press right click in LB there is not shown any reference of the selected item. I tried many different items in the level.

I’m quite lost and I cannot continue if I can’t make this work, any help??


Edit: I just discovered that if I drag or right click to import an object that is already in the level blueprint it allows me to add it again, this does not make sense to me :frowning:

Problem solved if to anyone else happen something similar here is why:
I’m using level streaming and I have around 5 sub-levels, for some reason in many months of work I never needed items reference inside one of the sub-levels within my main level blueprint.
So If you want to be able to reference the item remember to move it in the persistent level or you can reference it in the sub level blueprint where the item is stored.

I hope it makes sense.

Good luck with your projects :slight_smile: