Drag and Drop failure

Hello,
i am trying to drop fbx files in the content explorer but i am unable to. The mouse pointer turns to a stop sign and no importation is allowed. Another issue that simultaneously appeared is when i click on the Launch button is the editor the usual menu that contains all the projects is not appead but instead the last opened project is loaded.
I have searched for possible solutions and i concluded that this is an engine’s bug. So i report it.
I need the engine for my phd research so i will greatly appreciate your help.

Thank you in advance.

Hello docie,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce these issues in a clean proejct?
  2. If so, could you provide a detailed list of steps to reproduce these issues on our end?
  3. Could you try verifying your engine?
  4. Does this happen in later versions of the engine?

1,2. No project allows drag and drop imporation. I open the projects normall and when i try to drop the files inside a folder the pointer turns to “block” sign.
2. Veryfing? do you mean to download a new version? the current built is set over a year now.
3. It happens even in 4.11 version.

I tried to import the fbx using the file system and are imported properly. Although the drag and drop method is a usefull feature due to the large number of imported files my project requires.

Thank you!

Just to double check, if you drag the item over and you wait for a few seconds does it eventually allow you to drop the item? The reason that I ask is because it will sometimes show that the operation is not allowed at first, but after a few seconds the symbol will change.

No the common temporary block is usual and it was this feature that confused me in the beginning. The imporation is not allowed even after several seconds. Do i have to uninstall the engine? i do not want it because of the large number of projects i manage.

Hello docie,

Could you do me a favor and try verifying your engine build (example below)? Could you also make sure that none of the fbx files that are being dragged and dropped are empty (no mesh)?

Example:

50416-verifyenginehelp.png

Not sure if this helps any bit but Ark Dev Kit is having vary similar problems with copying GenericMod by dragging.

  1. The FBX are not empty.
  2. The importation is not allowed after the verification.
  3. The drag and drop does not function at any version (i downloaded and tested 4.11.2).
  4. There are not plug-ins installed on my engine.

If you are executing the engine as Administrator you cant drag and drop files into it.

I have set the Launcher to be launched using by default administrator privileges. Is there a setting that sets the launching of the Engine itself as admin?

Hello docie,

After further testing I was able to reproduce this issue on our end. I have written up a report ( UE-31294) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

So thanks for the assistance and i hope this issue to be solved.

I set the UE4Engine application to be executed as administrator and the problem remains.

yes, you cant drag and drop using UE4 as admin, im guessing is a matter of privileges, since file explorer is not launched as admin.

one more thing you cant do if you have set the engine as admin is doble click the project from the engine launcher, it will say “Failed to launch editor”, same happens if you double click the project uproject file. only way to open it is launching the engine and openning it from it. how do you open your projects?

I open the engine using the launcher but even if i open the application from the file folder the problem remains.

As workaround for this annoying permission issue, following truly will help:

Especially for UE4 d&d import/export on Windows 10, I’m using an non-Microsoft file browser now, which starts as administrator by default now. So I’m able to drag files from it to the admin privileged UE4-editor. My choosen one as example is “FreeCommander XE”. A BIG benefit:
a) you’re able to customize your file browser the way you really like it for your developing workflow (ie.views and favourites)
b) you’ve got 2 splitted screens (separated directory trees), which make it very simple for comparing and transfer
c) and last but not least, by opening your “developing-filebrowser” you’ve got your last used folders or predefined startfolders in front quickly

Happy file-dropping :wink:

I am aware of this particularity of the Engine but this is non applicable here. The problem solved only when I installed and used a new version of the engine.

My issue was a little different. I would drag and drop then nothing would happen. This is the fix I found: When you click and drag onto the content browser wait a moment for it to register you are copying something. I was clicking and dragging then dropping immediately. If i wait 2 seconds before releasing the left mouse button a loading wheel appears and then it realizes you are about to drop something. This is for v4.15

edit (the ‘do not enter’ sign would pop up for mine but waiting a moment allows unreal to register the drag and drop as I described above)