Downloading Metahuman in the bridge never ends

I edited my character in Metahuman website, and when I try to download it in Quixel bridge, the download never ends. It goes up to 88%. It starts downloading again. I tried several times, what could be the reason?

I’m goes up to 0%.

I’m having a similar situation.

It just refreshes the page so I can’t even download metahuman period.

I am having the same problem. It gets to 88% and then just stops and starts over. Has anyone figured this problem out or have a solution?

Isn’t there an answer to this problem? I have this problem too :frowning_face: :slightly_frowning_face: :face_with_diagonal_mouth: :confused:

I had this issue, it either never finished or took hours to complete.

However, latest UE and Bridge seems to work fine and it downloads, while a little slow, much faster and does complete… maybe a update fixed it somewhere.


Have this problem too, with latest software ue 5.2.1 and latest quixelbridge

I have UE5 the quixel bridge comes as a plugin and I am not able to download my metahuman the download is so slow that it would take me 2 days to download a metahuman can someone help me with the issue should I use VPN ?