Download

Downloaded 4.10.1 and keep getting Trojan (avira-warning)

As said.

After downloading it my Avira keeps popping up with an Virus warning of Trojan; TR/Kazy.78336.20

just curious why that pops up.

Most likely just a false positive (aka over-zealous anti-virus :D). Nothing to worry about!

Hi, this is an old thread, but i just got a virus alert as well with the newest update. Since my AntiVirus (AVG) detected a specific named incident (and not that generic behaivior detects you would expect as a false positive) and it was not a created mod but the dev kit itself, the devkit either got infected for real, or the developers should check the detection method for that virus and analyse what causes the detection.
virus.png
Since AVG most likely detects this via known virus signature you devs should really look into this if you dont already know the reason.

Regards,
Some IT guy with close to little knowledge in that field :smiley:
but still …

I’d be amazed if it was anything other than a false positive. I know very little about this topic. Probably flagging up the fact they’re named a certain way - such as “swarm” and “control” or such. Plenty of people are downloading the same dev kit, and presumably, their virus software is not flagging this as an issue. I’d not worry much about this, assuming you are getting it from the official, reliable source.

Okay. But the last part isn’t necessarilly an argument, because most people assume a false positive whenever a virus alert pops up :wink:
Anyway, maybe you have a tipp for me (since i found no other thread where that was discussed) to solve the resulting issue:
i made an exception in avg to ignore everything from the ARKDeVKit directory, but the launcher is still verifying till eternity (~15min) starting several times form 0% again and appears to be downloading a really small file at the beginning. The final message after that ~15min is then Installation failed, The Installation is corrupt.

The debug output is: [2016.01.07-18.32.53:684] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Projects/ShooterGame/Content/PrimalEarth/Structures/Explorer_Chest/EnglishModernChest/MIC_EnglishChest.uasset
[2016.01.07-18.32.53:684] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Projects/ShooterGame/Content/PrimalEarth/Structures/Explorer_Chest/EnglishModernChest/SM_EnglishModernChest.uasset
[2016.01.07-18.32.53:684] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Projects/ShooterGame/Content/PrimalEarth/Structures/Explorer_Chest/EnglishModernChest/Textures/T_EnglishModernChest_D.uasset…

or
[2016.01.07-19.22.47:333] 0]BuildPatchServices: Verifying install
[2016.01.07-19.22.47:910] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Engine/Binaries/DotNET/SwarmInterface.dll
[2016.01.07-19.22.47:933] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Engine/Binaries/DotNET/UnrealControls.dll
[2016.01.07-19.22.58:720] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Engine/Binaries/Win64/Linux/UE4Editor-LinuxNoEditorTargetPlatform.dll
[2016.01.07-19.22.58:720] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Engine/Binaries/Win64/Linux/UE4Editor-LinuxServerTargetPlatform.dll
[2016.01.07-19.22.58:720] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Engine/Binaries/Win64/Linux/UE4Editor-LinuxTargetPlatform.dll
[2016.01.07-19.22.58:977] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Engine/Binaries/Win64/UE4Editor-ActorPickerMode.dll
[2016.01.07-19.22.58:977] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Engine/Binaries/Win64/UE4Editor-Advertising.dll
[2016.01.07-19.22.59:028] 0]BuildDataGenerator: ERROR VerifyFile cannot open D:/Programs/Epic Games/ARKDevKit/Engine/Binaries/Win64/UE4Editor-AIModule.dll

for 2005+ files. sadly it is right, they simply dont exist, but resuming the installation won’t get them.
Any idea what i could do to get them without downloading the 52GB again?

PS: i got the launcher from Workshop aka the official one, just i case you wondered

Edit: __________________________ Solved ____________________
completly turning AVG (The anitvirus) off did the trick to get the installation through. Not the best thing to do, but a man needs to mod :smiley:

LOL! No, they don’t check the filename…
Such false positives can be the result of the so-called heuristic search (see: Win32/Heur). Antivirus software that is checking for virus-signatures can only detect known viruses (that’s why only idiots think that Antivirus software is protection enough). The heuristic search is an attempt to identify new, unknown malware by searching for suspicious function calls etc.
My guess: the Swarminterface.dll is connecting to the internet and therefore can appear similar to certain Trojans and UnrealControls.dll might intercept keyboard-events and can appear similar to a keylogger.

@TheLyingTree: make sure that the Antivirus software has not deleted files from your install! I had the problem that my AV was secretly deleting libogg.dll and then my installation was corrupted, until I found out and copied it back.

TR/Kazy.78336.20
is actually a very bad Banking-virus. I doubt that this was coming together with your UE4 installation! Since it keeps popping up, it shows that Avira has difficulties to get rid of it!
If I found such a virus, I would wipe my harddrive and make a complete reinstall of windows, unless you have a clean backup somewhere. Just my two cents…
(BTW, I am using a separate Ubuntu install just for online-banking! :wink: )