Download

Download the engine built by another computer then open project with it, but engine wants re-compile

I downloaded (from Perforce) an engine built by another computer, and I tried to open our C++ game project by it.

When first time opening the project, I have the same “EngineAssociation GUID” problem like here, so I do a “Convert in Place” for my project. However, this action triggers the game project to be re-compiled, which further triggers the engine to be re-compiled. Furthermore, I tried to create a new C++ project, and the engine still compiles when I build this new C++ project.

The “EngineAssociation GUID” is fine for me, the game project can be compiled, however the engine should not. Anyone knows why the engine wants a re-compile?

The command line used by my game project is below: Running E:/XXX/Engine/Binaries/DotNET/UnrealBuildTool.exe MyGame Development Win64 -project=“E:/XXX/MyGame/MyGame.uproject” -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE -2015, you can see a -editorrecompile parameter, maybe the key is to stop generating this parameter or the whole command?

The re-compile is triggered like the following 1142563b7db84786d29bf86f8dd6fbfa45146c93.png

Thanks.