Download

download failed because you may not have purchased this app

Hello,

i have this kind of issue when I am uploading my game to Google play. They already publish my app (alpha test) but I tried to download it from Google play and this is what I see:

I don´t know where is the problem. My build from engine is correct, I mean, I tested it and it was working. Maybe I did something wrong in Android Studio when I was trying to package it into that App Bundle?

Please, do you have any advice?

Hey i have the same problem do you found a fix for this ?

Hello, actually I did. I made .obb file, which I am uploading together with .apk file.

I uploaded my .apk (arm64 and arm7) to google play with the correct .obb files attached for each. I’m still getting error. Could you elaborate on what you mean when you say you uploaded them together?

I got the same error and I don’t understand what i’m supposed to do …
I got an error if i’m trying to install directly from my installer in the ASTC folder

having the same issue! does anyone knows the solution

just ran into this ourselves. long story short, you need to wait for at least 4 HOURS after “confirming and starting” your rollout.

you can double check this by looking at the obb version getting pulled down to your device with the adb(.exe) tool.

you can find most of the details in your [FONT=Courier New]Install_xyz-Android-abc.{bat,sh} file. but, basically look for your obb version like this:


adb.exe shell ls -lR /sdcard/Android/obb/

and you should see something like this:


. . .
/sdcard/Android/obb/com.YourCompany.GameName:
. . .
-rw-rw---- 1 u0_a369 sdcard_rw 1772412884 2020-09-03 09:32 main.46.com.YourCompany.GameName.obb
. . .


note the “store version number” (seen here as “46”).

keep looking at this until you finally see the newer obb version getting installed to your device.

again, it seems to take up to 4 HOURS to see this finally getting installed to the devices. i’m guessing this is presumably to give developers/publishers time to undo any “release to production” for whatever reason.