Download

Double Sided Geometry

I have a simple plane that I have made for a ceiling and a floor for my level. Here are some screenshot’s of it.

&stc=1

&stc=1

As you can see in Maya LT it is just one sided. I made it this way as it is only one side that is going to be seen. The issue I am now running into is that for some reason when I build my lighting in UE4, light is still coming through as if the mesh isn’t there. I have turned on ‘Double Sided Geometry’ in the model viewer in UE4 but that doesn’t seem to be working. Is there something I need to do to my model in Maya LT?

I did check what the internet has and people are talking about making double sided shaders and there was an answer on how to get Maya LT to render it double sided but nothing for what I need :frowning:

Here are some shot’s of it in UE4, the floor is also a plane similar to the ceiling mesh but upside down and the opposite way :smiley:

&stc=1

&stc=1

&stc=1

As stated above, I checked ‘Double Sided Geometry’ in UE4 on the model’s in question already and had no luck :frowning:

You have to enable it in Material settings. Just open your material and turn on in settings “Double sided”

You can also select the static mesh in the level and go to the Lighting section of the properties and check the Cast Shadow as 2-Sided.

I have a similar need. Ive had no trouble at all up to now with my design elements, but now I have purposeful hole in a cave, which leads of course to another tunnel, but ‘getting there’ requires player to go into backfaced area of mesh. I can clearly see all of this in 3d modelers Im using, but the rest is causing some grief.

I made some progress thanks to this thread, as in at least I can now ‘see’ the area directly ahead of hole, but going through hole and stepping onto cave area as planned, and player falls through. I just said to use two sided in textures settings, ty for that info , but I collision isn’t working at all atm.

What setting am I missing so this doesn’t happen ?

If I cant fix, I have another way of doing it, buy the design was meant to work in this fashion if possible.

Any idea ?

TY
lee

SO any ideas on how to get collision working under these circumstances ? thx
lee

Hey Neighborlee!

When you go into the static mesh editor, you could change the collision complexity. I assume you want to go through the hole, so you need to have the option “Use complex collision as simple” enabled. This is a more performance intensive collision, but you can use them as long as you don’t use too many meshes with the collision enabled. It should solve your problem.

f445ef7e9162acc6f677c0f02af0f1e2cce3ade2.jpeg

This is in no way related to ScrotieFlapWack’s problem.

Start a new topic…

Hi. I can’t find the settings place you mentioned in Materials to turn on double sided. Can you please elaborate?

Here it is in Material Editor, material properties…