.dotnet problem when packaging project

Hello! I am trying to package my project but I have been fighting with .dotnet problem and I have done literally everything I could find on internet. I have Unreal Engine 5.1 (release) built from source. The error that I get is shown in picture.

you built the engine on your side or downloaded the normal way? if first did anything else builds or just this specific project?

Hi Ilari, Welcome to the Forums,

You might just need to restart your PC.

If you install the version of dotnet from this link and restart your PC is the problem resolved?

I have built the engine from source by myself. I did whole engine rebuild today and made whole new project and still the same issue is here.

I have done that but not working either. I don’t know what has happened in these last two weeks because I was able to package server build two weeks back and now I cannot package anything.

Strange, If you open a command prompt and type dotnet do the dotnet options display? (This is just a check to make sure that environment variables are working)

I solved the problem by an accident… I ran UnrealEditor-Cmd.exe instead of UnrealEditor.exe in .\UnrealEngine\Engine\Binaries\Win64 folder. Then the engine opened and started to do some queries for those SDK:s and fixed the problem.