Download

Door Won't Open

Yeah I know, it’s another complaint about doors…

So the other day I downloaded Unreal Engine 4.1 and, today, started running through the “Your First Level” tutorials on YouTube. I’m up to Blueprint Pt 2 for opening the door, followed everything on the video and jump in game, and the door doesn’t open. I’ve tried resizing the door, making sure it isn’t overlapping anything and the object is set to Moveable. It just stays put no matter what.

I’ve followed all the instructions, and the compile window says it’s ok. The only thing I haven’t done is set up the source code though, unless this is a requirement, the lack of it shouldn’t be affecting trigger events.

You don’t need C++ source code if it’s a Blueprint project. Can you post a screenshot of your scripts?

http://i.imgur.com/3xZBOKn.jpg

I’ve simply followed the inputs to the letter. It just isn’t working…

That said, 4.1 has only been out a week so it could be something’s broken.

One thing that might help diagnose the problem is inserting breakpoints in the script to see what’s actually happening. For example, if you select that “Begin overlap” event and hit F9, a red circle will appear on it. When the event fires during Play or Simulate, the game will pause and open the graph. At that point you can hover over the “Other actor” pin coming out of the node to see what activated it. If it all seems in order, you can use the “Step” button to follow the graph as it executes one node at a time until you see something that seems wrong.

There could be a couple of possibilities - either the trigger isn’t colliding with the player, or it’s set up in such a way that bits of the door itself are triggering the end overlap event when it tries to move, causing it to immediately reverse the timeline. So by using the breakpoint, you can see what actors are triggering your overlap events and figure out if you need to change the collision channels on them.

I tried breakpoints and they didn’t reveal anything, though I think I’ve identified the problem. Due to the orientation of my room as opposed to the one in the video tutorial, my door has to slide along the Y-axis, so I created a vector graph for that direction; whenever I compile, however, the engine forcibly switches to the X-axis as if it only wants to receive input from there…

I will try rotating the entire room 90 degrees and then add a change the vector graph to X - if it works that means there is a glitch in the timeline not scanning for vectors in all three axis. If it doesn’t, it means there is a problem with the release itself. In either case I will update you momentarily and post a report to AnswerHub.

[UPDATE] So, after doing all of that, and changing my TriggerBox to “WorldDynamic” which strangely remained set to “WorldStatic”, nothing’s working still. Best guess is something got screwed up when they updated it to 4.1.

Is there any chance your door is starting at 0,0,0 in the world? That’s seems like a very odd thing to do, adding actor location to actor location. Why not add a manual offset for your test? Like 10,0,0. No need to rotate your level or anything.

When you say “I created my vector graph for that direction” I am not sure what you mean. I don’t see any manual vector orientation anywhere in your blueprint, it’s adding its own location to itself which is strange. I’ll have to check out the tutorial to make sure it really suggests that.

On second glance at that screenshot, it looks like you might want to check which actor you’re actually telling it to move. Judging by the icon, the actor named “SlidingDoor” that you have connected to the “Set actor location” function is actually your trigger. You’ll want to replace that with a reference to the sliding door mesh you want to move.

Thanks for all your help, Thomas…

The mistake I made was during my naming conventions, where I did indeed use the trigger as the moveable object instead of the door.

For those who find themselves on the Y-Axis, and feel that the TimeLine is defaulting back to X-Axis, you can do one of two things:

A) Cntl-click everything except the sun and fog and stuff, and then group (cntl-G) and rotate. But you may find that you still are watching the timeline default.

B) Check to make sure the numeric value placed in the second breakpoint on the timeline actually recorded your second value; you may have to use the value slider in the field because every time I tried to manually enter a value in the field, it would default back to some very small value. If you use the value slider on the right side of the field and use the mouse to input your 120 units, the value stays and the Vector field stops defaulting to it’s original state, which is with X-Axis checked as opposed to the Y-Axis. So for those working a different axis, insure there is an actual value in the field with the value slider, save, compile, and you may have an immediately working sliding door.

I wish to thank Epic Tutorial guy for these tutorials, it really makes the hands-on practical development curve a pleasure such that when I run into the bugs of life, I don’t get too frustrated.

Thanks so much.