Don't know why crouch animation is not working

all the blueprints seems okay but the crouch animation is not working, dont know why.

i fixed it but the animation seems odd and not in place where it should be

From the input action of pressing the crouch button, make sure it’s actually setting crouch to true when pressed and set it to false when released. So just add it onto the crouch and uncrouch you already have.

The center of your mesh is at 0,0,0 in whatever 3d modeling program you’re using so your hips are at 0,0,0 when it should be your feet that are at 0,0,0. This means that whatever animation you play, it is centered from the hips and not the feet which is what is resulting in it looking like you’re floating. To fix this, edit the skeletal mesh in your 3d modeling program by moving it upward so the feet are at 0 on the height axis. As a result you’ll also have to edit the crouch animation so it has the correct height.

have you enabled root motion on the crouch animation?

yes and it becomes worse

You can edit the animation in UE4, open the animation asset (make a backup first by selecting the animation and CTRL+W) pause the animation and go at the beginning, select the rootbone or the one after it (depending on your skeleton) in the Skeleon tree tab in the left, then change the Z location finally press the + button (Key) and save.

I have the same issue and the solution was to do a translation retargeting to animation instead of the skeleton, in the skeleton itself but this will kill every root motion animation as the character capsule will not move with root motion animations and you will see them jumping out of the capsule boundaries also you will find many other artefacts in other unrelated animations