Don't know what to add as object wildcard

I’m creating a character creator in unreal and when I click the next button, I want the camera to switch from the follow cam, as part of the thirdpersoncharacter to another camera, that’s look at the torso. (Whilst the menu goes invisible for that transition.) I set up the other camera and created a blueprint for it and created a variable for it. Then when I’m in my UI menu blueprint, I cast to this blueprint to get the camera. This seems to work, except from I don’t know what to put as the object. Any ideas?

This is the blueprint I’m working in, I don’t know what to put as the object for the cast. I’m relatively new to this and use unreal as part of my college games course, so this is a solution that I came up with, after many hours of scratching my head and I’m hoping that this is the breakthrough I need.

You need a reference to your TCam_BP. If you need help creating references check out video #25 it may help you figure out how to create it.

Thanks, I did manage to figure out the blueprint reference, very helpful series you have thank you (got yourself a subscriber by the way) however, for some reason the camera just rotates around and doesn’t go to the camera. Could this be a problem with my TCamBP blueprint, as all I did was added a camera, clicked create blueprint and created a variable in it.

That’s all thats in it the TCamBP blueprint.

That’s my umg widget blueprint, I’m confused as to why the camera isn’t switching.

Glad the videos helped and thanks for the support. What do you mean by the “camera just rotates around and doesn’t go to the camera”??

It doesn’t switch to the other existing camera that faces the torso to look at it, it just rotates from the follow cam into the characters torso and stares at the stairs (as using thirdperson template). I don’t know why it’s doing that.

I have tried to see if deactivating the follow cam will fix it as, the other camera is already set to auto activate. I’m not quite sure what it could be? Am I calling the wrong object or is there something I have to do in my level blueprint. I’m not sure but I’m trying everything I can think of.

Hey sorry for the late response. I don’t think auto activate works that way. If it isn’t being used automatically then auto activate does nothing. Try setting that camera as auto active false, then when you switch, get a reference to that camera, set it to be active and deactivate the primary camera

Ah okay, thanks. I’ll try that and see if it works and don’t worry about it, it’s at least given me time to attempt to try more things.

Sure…let me know how it goes.

So I’ve tried what you have suggested by setting auto-activate to false (I did it via blueprints though not by the details in the world menu.) Then I set it to activiate and then deactivate the other one and it still doesn’t work. So I’m wondering if there’s anything wrong with my blueprint again, wrong order, etc.

As you can see I wanted to check if this was working by making it print the separate words. As you can see below it did print them, so I don’t understand why it’s still not working.

Not at a computer right now but I will play around with this tonight and get back to you. I am pretty sure the activate and deactivate are nodes you pull direct from the camera component reference not a root component. That’s the only thing I could see that was a little odd to me but I could be wrong. Will check it out tonight.

Just for reference I tried out what you said and linked the camera components by making a component variable, the issue still persists though.

The messages still do appear on screen though.

So I just looked through your BPs and noticed something as I tried to use the “Set View Target With Blend Node”. That node takes in an actor reference to then have your controller “view” be located. When I couldn’t get a camera component to be an input into that node I realized how you did so with a TCam, very tricky! But you actually made a Camera Actor variable called TCam within your TCamBP which was never set and is actually NOT anything related to what you are trying to do. That actor reference is NULL and does nothing. The node you are using “Set View Target With Blend” assumes you are switching from one actor to another and will thus be using the second actor’s “view” through its camera. So you can’t use that node with 2 cameras on the same actor. You need to find some other way to switch between 2 cameras on one actor smoothly but that node won’t do it as far as I know.

^ Yes… though it’s a bit clumsy, is possible use Set View Target with Blend with 2 cameras on the same Actor:

To get the needed Actor reference for Set View Target with Blend on a Character needing more than one camera, instead of using Camera Components, I’ve used Child Actor Components (with a Camera Actor nominated)