Download

Don't hide component attached to hidden mesh bone?

I want to attach a fire particle component to the player pawns mesh for when they are set on fire. I attach it like this:



Mesh.AttachComponent(OnFireParticle, OnFireParticle_AttachToBoneName);

However when i first person mode, because I’m hiding the pawn mesh, the fire particle also gets hidden. I can see it fine when i unhide the pawn mesh.

I’ve tried setting:


OnFireParticle.SetIgnoreOwnerHidden(true);

But it seems to have no effect.

Does anyone know how I can do this?

Why don’t you just attach another one in FPS mode to replace the other one ? It is just an idea.
Best of luck.

I ended up just attaching it to the pawn actor, then adjusting the translation to the bone location in the pawn tick. It feels a bit hacky though.

Any time you hide whatever it is and whatever is attached to it. All attachments will follow the base class settings if main(base class) piece gets hidden all its attachments get hidden also.

Nice to see you came up with an idea to fix it.