Download

Does Unreal Engine 4 support an Intel HD Graphics 3000 card?

Do you think the requirements will increase further down the line? Or decrease?

It’s probably a bit to early to say if the requirements will drop or increase right now. https://docs.unrealengine.com/latest/INT/GettingStarted/RecommendedSpecifications/index.html but those are the bare min and recommended requirements from the official docs. Considering the power UE4 can push out I am kind of surprised of the min requirements.

Ah, reading through that then, it appears that DX10 is actually the minimum-supported version. Makes sense I guess as there are few differences between that and DX11, almost like DX10 never existed it came and went so fast…

As for requirement changes, I doubt they will change at all. If they do, it won’t be for some considerable amount of time, say a couple of years at least.

Just clicked the Mac side to see the difference and it says

So it’s safe to assume if with the Mac version the HD3000 is temp disabled it is the same for Windows though it might change in the future from the looks of it.

In the minimum requirements, I noticed for Mac it says “HD3000 GPUs are temporarily unsupported”, but it doesn’t say that for Windows. Does it mean it works for Windows?

Can you open up simple scenes and use features like blueprint and add stuff in with the content browser? Please play around a bit (try to go into game mode and real-time rendering) and let us know what works and what doesn’t. It would be really useful it the basic stuff worked, I don’t plant on opening up a crazy project made for next gen games, just playing around with a basic scene and some other nifty features. If it works decently at least for you, I would probably buy it since my computer specs are almost exactly like yours (but without the nvidia graphics card)

I think that’s because at the moment their experiencing crashes at the moment, just tried it.

I tried restarting my notebook to test it - this time I created a new blank project (which doesn’t require Visual Studio), it had almost exactly the same results (crash). Only this time there was a minimized window about a tutorial which never appeared. After a crash, I can’t even get into the load project screen. My opinion is to wait for updates or buy a new PC.

Intel GPU for Game?
Hey, i advice you to get Nvidia or AMD GPU.
Try downloading and see if it works or not.

Best of luck!

This is weird, it says I have DirectX11 installed. Anyone mind taking a look at my dxdiag and see if I meet minimum requirements? http://pastebin.com/cXeRs4Hx

Apparently they will provide a refund if it doesn’t work on my system. I think I might wait a month or two and then buy it to see if it works at least up to what I would be using it for. I’m not sure when I’ll be getting a machine good enough to run it though.

https://answers.unrealengine.com/questions/12482/would-unreal-engine-4-work-on-an-intel-graphics-ca.html

If the issue is temp then it’s safe to say that it will be re-enabled at a later time since at moment it’s false information if there not meeting the minimal requirements that customers were told.

that is pretty low end on cards you should really consider upgrading if you can you do not need a top of a line card to run UE4 i have just a nvidia gtx 550 ti. but it works ok. but yeah…

I was testing UE4 on my older machine which has a AMD X3 440, 4gb ram and a GTX260(does not support DX11) and it works fine.

I happy to confirm that this engine is quite hardware tolerant, i got Core2Quad Q9300 2,5Ghz, 4GB RAM and Geforce 9600GT with 512MB VRAM (yes below documented minimal requirement of 1GB) and it works well enough to do some development on it and even better if you plan to do mobile game.

I ran thru Marketplace projects:

-Example Content runs around 20FPS, on some heavier effects it lower heavily, mostly in material roughness. Some things not didn’t work, for example in “Effects.umap” 2nd example with red falling flames and volume cloud didn’t work, in “Decals.umap” the shiny unreal logo half tansparent, i kind of suspect it’s due fact that my GPU does not handle DX11 features. But most of stuff works including PhysX.
-Tappy and Ninja works around 40FPS, fast enough to not see any slowness.
-Shooter Game is more demanding but runs jumps between 10-20FPS, when it loads up the map for the first time editor almost freezes but later is ok
-Reflections Subway suppricly runs better then shooter nearly 20FPS

I know most of people would not be satisfied with those results, but for me it’s good enough to test out what i’m coding:)

So hopefully there is a config or some changes that can be made to bump up the live viewport performance and if anyone has any to share they would be appreciated.

I know I am running this on a low spec machine so lets get past that and see if we can get some extra performance out of it anyways as this is just my portable fun machine and would love to be able to use UE4 on a whim when out. The specs are an i3-3227U cpu with onboard hd4000. 8gb ram. Using flappy chicken as an example I get ~12fps when in editor mode and gameplay seems to be much better and smoother.

My goal is to have something that is atleast usuable for working with as even a blank scene gives me ~17fps when looking straight ahead. Disabling the grid gives me a 3fps boost which I find very amusing so perhaps there are other easy fixes that might get the editor more performance.

My laptop has Intel HD graphics 2500> Core I3 3.31Ghz> 6GB RAM> Win7x64> 500Gb HDD! And the UE4 is even running a bit slow!

My current laptop (X1 Carbon) has Intel HD 4000, but I haven’t installed UE4 on that yet. I did have a high-end MBP until about 3 months ago, but I’m considering buying another again.

Is anyone doing dev on a Mac Book Pro? I’m looking at several models, but I don’t know if Intel Iris Pro graphics will work. The $2,600 15" model is the only one with a dedicated GPU. http://store.apple.com/us/buy-mac/macbook-pro

I already own a nice laptop, but to deploy I to iOS, I obviously need a Mac, which is what is pushing me over the edge.

It works on my Intel 3000 HD laptop (Core i3). DirectX 10. It is a bit slow though. “choppy” you might say. Even at lowest settings.

Apparently the feedback is that they have found a bottleneck in the driver for Intel 3000. And are looking into it.
Mind you that was a couple of months ago.

Hope they get round to trying to fix it! :stuck_out_tongue: Probably turn out to be something simple like forgetting to carry the 1.

Can any one please let

if this system would support UE4 ??