Does this look right?

Today, I have begun to practice creating props and so far I’ve created 2 prop, curved window pane, and the bracket alongside.

My issue is the window is being reflected in a weird way. Does this have to do with the glass material? Is this because I don’t have enough polygons to make it look more realistic? Could it be the lighting that make it look that way?

I should probably just keep forming my level together with the corrected lighting and then see what should be fixed/done.

Hello there!
You have not assigned smoothing group to your mesh thus you see facets. On your screenshot look at “Window_Pane_Large” - it’s has same issues as a glass version

Thanks for the reply! I didn’t think there will be a difference by deleting the phong tag (Cinema 4D) from the prop. I reimported the props and got a much better result from it! Although, the lighting from the glass may seem like an issue but as of the border, it look a bit cartoony with the new smoothness. (Haven’t added textures and stuff yet though).

Any tips I should know? :slight_smile:

Single smoothing group is not the best solution for this sort of meshes. I recommend to apply at least 2 different smoothing groups to your mesh. First to the top/bottom parts and 2 to the curvy surface.
Check out this mesh for reference

I changed the setting in the Phong (smoothing) tag to match the SM_ThinWindow you attached, and it did make a big difference. I think the reason for the other border being reflected down the end is because of the lighting which isn’t where it’s suppose to be. Is this better?

You can still the edge lines through the glass, but I think that’s because of the amount of poly I used (which isn’t a lot).

I’d also recomend using the Vertex Normal Tool Lite plugin.
It gives you more control over the shading.


Because of the adjusted vertex normals on the right cube, the smoothing creates a nice rounded edge effect even without using a normalmap.

The triangulation of faces on shapes like cylinders is causing the vertex normals to have some missalignment (as you can see in the top view of the right cylinder).
This creates a noticable shading issue on these kind of shapes. (3D view cylinder on the right)
It’s fixable as you can see on the example on the left (top view) and the cylinder in the front (3D view).

I appreciate the great tip! I’ll try this out first thing when I wake up. :smiley: Modeling between 2 software can become really complex. :confused: Love to solve problems though as long as I’m learning.