Does the Event Begin Play on a level blueprint only fire the first time the level is loaded?

I have been fighting and issue with my level blueprint for hours now and just figured out the issue.

When I run the game in the editor window or a separate window it will fire the EventBeginPlay on the level blueprint every time that level is loaded but when I run as a standalone game it only fires it when the level is first loaded and not every time you load it.

My main menu has a camera pointing at a scene and a main menu widget. When I first turn on the game it goes to the main menu and it is all fine and dandy. I then load the first level and then pause the game and quit to main menu. When I return to the main menu level It is not using the camera that I assigned because it is not firing the EventBeginPlay when it reloads that level.

Does anyone know another way I can control this camera, there is no way to tell a level blueprint to do something that I know of.


Same Prob here

Hello Overwatch04,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved?

I started a fresh project and set up a simple menu widget with a button to load a map and pause widget with a button to load the main menu map. I cannot reproduce the issue. It seems to work on my original map after messing with things for a week or so and since it has been three months I cannot remember if I fixed it or took a different approach.
I do know something was keeping it from firing because I had placed PrintStrings on the level blueprint “EventBeginPlay” for debugging purposes since when you run the game in standalone you cannot see the nodes being executed and they fired when I first opened the game up but when I loaded the level I used as a main menu it did not fire.

I am happy here that the issue is no longer occurring. I am going to mark your last comment as the answer. If this issue happens again please feel free to reopen this thread with any additional information you may have to help reproduce this issue on our end. I will be more than happy to assist you further.

Make it a great day