Does that mean the plugin has a different version or anything else? How can I solve it? Should I just update plugin?

If you are encountering version compatibility issues with a plugin in Unreal Engine, it’s possible that the plugin you are using is not compatible with the version of Unreal Engine you are using. In this case, updating the plugin to a version that is compatible with your Unreal Engine version may solve the issue.

Usually if a menu similar to the one you have appears, it means that the engine will update it to work for the engine version you are currently on. It can fail to build or update, however the engine will still try to set it up properly.

You can’t downgrade tools in the engine. For instance, something made for 5.1 can’t be used on 5.0.