Does not recognize visual studio 2012

when I try to “Generate project files” with the right click on the project I get and error.
GenerateProjectFiles ERROR: A valid version of Visual Studio 2012 does not appear to be installed.

I have uninstalled everything and made sure that vis was working then reinstalled but it still has the same error.
What have I missed?

well i sorted it out I had to uninstall all of the vs 2012. I also forgot I had vs2010 installed which may have created some headaches.

thanks Rama for the help either way

you’re welcome!

Dear Emile,

Welcome to the forum! :slight_smile:

In your actual project folder, try right clicking on your .uproject and select “generate visual studio files”

then double click the .sln file that gets created to open it in VS

then follow all the steps in my tutorial in my c++ thread (just the first post), and do make sure to expand the spoiler parts as they contain key information and pictures

after you’ve done all that and compiled your project at least once directly in VS via the method in my tutorial (right click on the editor build and build that)

then let us know if you still having issues



I don’t think this is the problem as its not generating the files at all. its erroring before then. the sln never gets created.

Hi Emile,

I know you solved your issue but if you face or someone else face this issue again note the below points:

  1. Unreal Engine 4 detects VS2012 installation using [Environment Variable][1].
  2. So if UE4 fails to detect VS2012 follow below steps:

a. Open your Environment Variables Settings.

b. If you dont have the selected entry in the above picture then Press New…

c. Then add VS2012\Common7\Tools folder (mine is D:\Microsoft Visual Studio 11.0\Common7\Tools\) as variable value and for variable name add: VS110COMNTOOLS (Case sensitive…i guess)


PS: You can have both VS2010 and VS2012. It wont cause any problems. I have both of those installed as you can see in the above screenshot (VS100COMNTOOLS is VS2010)

very great info to know, thanks Satheesh!


Thanks, this solved my issue!
I had started installing MSVS 2013, but aborted the install. It had set VS120COMNTOOLS in the environment variables, so deleting it solved my issue with generating project files!