Download

Does anyone know how to import updated skin weights from maya > ue4

I’m trying to import from maya 2018 my updated weights on metahuman to ue 4.26, I have tried for quite some time now to do that without success. I have physics on the body in ue4 which drags body from the face and creates empty spaces between body and face,

I have tried to import updated model with new skinweigths directly to the skeleton with same name in ue4 and that just created some dublicates mabye because model have 4lods. When I open the skeleton f_med_nrw_body, i tried to reimport each lod for them self and that works but for some reason in ue4 you cannot reimport lod0 (base), and in maya I can only paint weights on lod0.


I don’t know of a way to import only the skin weights part of a mesh, I’d have to re-import the entire mesh.

sorry I might not been clear, I’m trying to re-import skin weights for the entire mesh (skeleton body) and when i’m done with body I will have to do the same with mesh for the face.

Have you done any tests like exporting the base mesh saving out of Maya and then just reimporting without touching and weights to see if you can get it working?

Thanks for replies, I did what you said. Created a new maya project bridged metahuman over, and then I only removed boots and it worked, it worked when I exported skinweights also for body. Dont know why it didnt work last time since it’s the same files I exported from maya.

Okay so to the next problem, does anyone know why the head skeleton in maya does not match up with skeleton in ue4, it will just say that hierarchy of the bones is not correct and then is completly destrois the head.


Check that the root is just called root, I don’t work with Maya but in blender if there is a duplicate name it adds .001 to the end of the name if there are two root names, in c4d it keeps duplicate names. So just check this in Maya as I couldn’t make it out from your image you uploaded.