Does anyone have the TTS engine working in Unreal 5?

I have followed the UE documented tutorial to the letter:

I have installed the Text to speech plug in and activated it.
I still get no sound .
Does anyone else have this problem and if so how did they fix it?
I tried one suggestion of adjusting the communications section in windows sound to ’ Do nothing’ but still no luck.
Any advice would be greatly appreciated

2 Likes

Hi, found this searching for help.
Can not get it to work either, playing other sounds works fine in project.

Did you find out how to get it to work, or are you still having issues with it?

Yeah, I’m also having the same issue, no sound… I wish there was more documentation on this topic.

1 Like

any luck on this?

I am also unable to get it working. I guess they put it there and it will be enabled at a later date. No sure???

Hi, I have the same problem - no sound at all. The Plugin looks really interesting.

This warning in the log is strange, which appears when calling AddDefaultChannel as shown in the example:

LogTextToSpeech: Warning: The requested channel Id: ChannelOne already exists.

So I wondered: how can the system know about the channel id at very first creation to complain that it already exists?
I found, that Channel One as in the documentation example seems to be some kind of default. Using a different Name does not produce this warning any more. In the C++ header file, I found “This will not create the channel if the provided channel id is not unique.” So it looks like adding a channel is not needed at all as Channel One always exists.

Testing with different name does not work as well, also trying not to create any channel and relying on the default Channel One.

Testing status:
DoesChannelExist, IsSpeakingOnChannel, IsChannelActive, IsChannelMuted return true + true + true + false in all cases, where a channel exists. If doing a RemoveAllChannels, these return false. But the TTS system does not produce any warnings in the log at all, if calling SpeakOnChannel for a non existing one and just silently fails…

It looks like it is time to check the source code … :slight_smile:

1 Like

For me, TTS does not work when testing while in the editor. It works fine when selecting “Standalone Game” or when the game is packaged.

Seeing as the “Text To Speech Quickstart” specifically shows testing in the editor, this is probably a bug. I’ve submitted a bug report for this.

Also, the warning about the channel existing is intended. It does not create it if one with that id already exists. When playing in the editor, it seems to keep this channel around, even when you stop playing. So the next time you play in editor, it will already exist.

Hi, I’m having this problem too. I tried all run modes, including the packaged game, but nothing worked and there was still no sound. :sob:

I have the same issue. It’s a pity that this plugin should work well.

Oh, this is interresting. Thank you for sharing!

Hello! We are working on a more robust fix for this right now, but in the short term, it is likely you will be able to resolve this on your end by going to your Master Submix and setting the “auto-disable” paramter to “off.” You can find your Master Submix in the Audio section of your Project Settings.

We are currently investigating why auto-disablement is leading to this behavior.

2 Likes

This is the publicly reflected Jira, if anyone wants to track this issue: Unreal Engine Issues and Bug Tracker (UE-161327)

2 Likes

Thank you for your solution, the plug-in works nice, but unfortunately, it doesn’t seem to support other languages, such as chinese? :sob: