Download

dodgy shadows on rotating meshes

hi, I need a little help to work out what’s causing this and what I need to do to fix it, it seems to only happen on meshes that rotate (happened to the wheels of a vehicle/ rotating edge of a UFO and now my ball), I know I am missing something but I don’t know what.

here’s a vid.
https://youtube.com/watch?v=NBEba225BGE

you can see the problem in the first 15 secs of the video, one half of the mesh displays shadow and the other half is lit but its not correct to the light (the light is straight up pointing down) and when I start moving forward the shadows go all over the place. the material right now only has a single texture and is set to be used with skeletal meshes, I get the same result using any type of light I put in my level.

anyone got any ideas on how I fix this?

thanks.

Not sure if this is your problem or not but make sure the object you’re using is set to “moveable”

its a skeletal mesh and the only thing I found that can be set to movable is the capsule component in its BP so I don’t think that’s the cause of this weirdness, it might have something to do with one of the materials settings or something.

I managed to fix my problem, I had to remake my project using a static mesh instead of the skeletal mesh and the lighting looks ok.

here’s what it looks like.

https://youtube.com/watch?v=ZhTg2dWp2TY

I still don’t know what caused the shadow problems (maybe its a bug) but its good enough for me now:).

Don’t know if the skeletal mesh ball was using a physics body or not, but if it was then you’d need to make sure all of the mesh is inside of its bounds. Otherwise lighting can go crazy like that.

I love how smooth and accurate it rolls, btw. :slight_smile:

it was set to be a physics actor so that could well have been the issue, I’ll have to remember that for next time:p

thanks:), although it rolls a lot smoother then that video shows, it looks a bit glitchy in the video because I used cam studio to record it at 200FPS and then I converted to 50FPS to make the video file smaller.