Download

Documentation on Blender's unit scale is not working for me

Hi all. This problem I am facing is driving me nuts. Basically, I have watched GeoDave’s YouTube video and read the wiki documentation, which both discusses about setting Blender’s scene units metric a scale of 0.01. However, when I bring in the skeletal mesh into UE4, my object is huge!!!. I do not understand it; most people who have a scale unit problem are complaining that there objects are coming in really tiny. I am really getting me frustrated, as I have checked, double checked, and triple checked, that I have cleared the scale and rotation factors of my object before exporting to FBX. I have even tried deleting the object from the content browser and import it back in again, thinking maybe UE did not fully update the object. Nevertheless, I cannot fix the problem without having to scale the object in UE4 to the size I need, which come to find out, the final scale factor i get is 0.01. The same scale I had set in Blender’s scene scale. So to me, it sounds like I should of left Blender to metric and scale factor of 1, not 0.01. Is this apparently a typo in the docs? Should it be set to 1?

So, I am assuming that no one else had experienced this problem? That seems kind of odd to me…

I don’t know for certain since I haven’t worked with skeletal meshes from blender (only static meshes), but I’ve seen lots of comments saying that while the .01 scale for static meshes works fine, it messes up the skeletal mesh import so it should be avoided if you’re doing that. Also, not UE related, but using a .01 scale will also mess up a huge amount of the non-standard meshes (so like the stuff in the shift+a “add mesh” category that’s not a basic primitive) and have them way too small, needing up to a 100x scale, along with breaking certain addons completely.

It’s a little roundabout, but you can set up a file that has the proper arrangement and scale for static meshes, then another for skeletal, and pick the one you need before you start modeling.

uhm the name is “GeoDav” :wink:

ok i think the point your missing is that before you export you have to “apply” any scaling.

press Ctrl+a choose scale

the set up i use works for bothe static and skeletal meshes

any problems just give me a shout