Do we still need to download full source code for html projects in 4.7?

I have tried posting this question in the 4.7 thread but it keeps getting buried and unanswered. I’m just curious whether or not we need to have the full engine source downloaded for html5 projects. The release notes for 4.7 made it sound like we only needed emscripten SDK and to restart the editor. I have done this but my browsers do not show up under the launch menu (I have 64bit Chromium). Basically I want to know if all the steps in this doc:
Getting Started with html5

are still valid. If so what is it exactly that changed in 4.7? Thanks!

Install firefox, restart, if the browsers still don’t show up - Look up HTML5Engine.ini - make sure the paths match up with what you have installed.

I installed Firefox 64 bit nightly build and restarted but still no dice. The inside of my HTML5Engine.ini Looks like this:
[Audio]
AudioDeviceModuleName=HTML5Audio

[OnlineSubsystemMcp]
benabled=false

[SystemSettings]
r.setres=800x600

[BuildSettings]
HeapSize=1024

[HTML5DevicesWindows]
Firefox Nightly (64 bit)="C:/Program Files/Nightly/firefox.exe"
Firefox Nightly (32 bit)="C:/Program Files (x86)/Nightly/firefox.exe"
Firefox (32 bit)="C:/Program Files (x86)/Mozilla Firefox/firefox.exe"
Firefox Aurora  (32 bit)="C:/Program Files (x86)/Aurora/firefox.exe"
Chrome="C:/Program Files (x86)/Google/Chrome/Application/chrome.exe"

;all browsers on mac are 64 bit, 64 bit browsers can allocate more than 512MB of memory to around 1.5 GB. 
[HTML5DevicesMac]
Safari="/Applications/Safari.app/Contents/MacOS/Safari"
Firefox="/Applications/Firefox.app/Contents/MacOS/firefox-bin"
Firefox (Aurora)="/Applications/FirefoxAurora.app/Contents/MacOS/firefox-bin"

[HTML5DevicesLinux]
Firefox="/usr/bin/firefox"

[HTML5SDKPaths]
Mac="/path/to/emscripten/sdk"

All the browser paths are correct.

Is there anything else that needs to be done with Emscripten? I just installed the SDK like it said in the release notes.

Can you make sure your emscripten SDK is atleast 1.25?

In the ini section [HTML5SDKPaths] and another line for windows like this and make it point to your sdk and restart the editor.
`
[HTML5SDKPaths]
Mac="/path/to/emscripten/sdk"
Windows=“C:/path/to/your/sdf”

`

I installed the latest version (1.29.0):

I ran the web version but it seems to be installed properly. When I open the emcmdprompt everything checks out alright.

I still don’t see the browsers showing up.

Do I need to register the emscripten environment globally in the Windows Registery?

In the ini file SDKPath section add the windows path to the sdk.

  • [HTML5SDKPaths]
  • Mac="/path/to/emscripten/sdk"
  • Windows=“C:/Program Files/Emscripten/emscripten/1.29.0”

Now it seems like you haven’t followed through the installation of the SDK, use emsdk command to actually install and activate the sdk. Some of the folders are missing.

aha, now we are getting somewhere. So apparently the install that I ran when I downloaded the sdk did not install everything it needed to.
For future readers:
Open up the command prompt for Emscripten from where you have it installed, something like:
C:/Program Files/Emscripten/emcmdprompt

In the command prompt type: emsdk install latest

This will download and install the latest version.

Then add this to your HTML5Engine.ini file (C:/Program Files/Unreal Engine/4.7/Config/HTML5/HTML5Engine.ini) right under the line for the SDK Mac path.

Windows=“C:/Program Files/Emscripten/emscripten/1.29.0”

Now save the file and relaunch the editor.

I don’t see the Chrome browser showing up under the launch (the path is correct too) but Firefox is now there!

A super-noob but having the same problem and the above didn’t fix it.

What about the forward slashes you are using for Windows paths? Unless I’m mistaken, your screen shot is of a Windows Explorer but you are using Unix-style forward slashes. Shouldn’t those be back-slashes?

Thanks.

Sure enough, I changed all the slashes to forward-slashes, despite this flying in the face of my understand of Windows, and I now see the browsers under the “Launch” drop down.
ok.