Do we have that old Anim Rotation Only?

In UDK, we had Anim Rotation Only setting which fixed some weird skeleton poses. Do we have that or something similar in Rocket?

Hi Satheesh,

We now have control over the individual bones. Open the SkeletalMesh in the Content Browser, and then in the Skeleton Tree note the Translation Enabled checkboxes. Turning these off will make the bone be ‘Rotation Only’.

I hope that helps.


Very nice. Thanks Stephen. :slight_smile:

reviving this discussion, is it still somewhere in unreal 4.15? I can’t find it

Also looking for this in 4.20 and can’t find it :frowning:

,Found it. It’s hidden by default. In the SK File, In the Skeleton Tree, up at the top of the menus is a drop down that says Option. Click on the little down arrow and turn on Show Re-targeting Options. You will then get menus to the side of each joint. I switched it from Animation to Skeleton to get the results I was looking for. There’s a few others and I’m not sure what all they do, but you can do like I did and switch between them until your animations look like they are playing correctly.

I found where it is now. It’s in the SK (skeleton) file, in the Skeleton Tree. The menus are hidden. Up at the top of the menu there is an Options dropdown. Click the little down arrow and select Show Retargeting Options. Dropdown menus should appear by each joint now in the skeleton tree list. There are a number of options in there, but changing the joints I wanted to affect from Animation to Skeleton got the results I was looking for. I don’t know what the others do, but I just switched between them and went back and looked at my animations until I saw what I was looking for.