DLL Missing for Installation

Hi there,

As soon as I begin to install the ‘UnrealEngineInstaller’ I get a warning for a missing DLL to install. It then immediately cancels the installation. I am assuming this is my anit-virus blocking installation? I have tried to download a couple of times so I believe it is this, I am just looking for confirmation or any other theories. I cannot temporarily disable my anitvirus so alittle stuck…


Hi KeyVis,

What is the exact error message that you are receiving?

A warning window appears and says the following below:

“There is a problem with this Windows installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.”

Im assuming this is either antivirus deleting it or something wrong with the actual installer package. Though I ahev redownloed multiple times.

I have seen a few posts with this issue. Can you check to see if the posted solutions in this thread are any help? DLL required for installation! - Platform & Builds - Epic Developer Community Forums

I suspect you will have luck by running the installer as administrator(with elevated privileges).

Hi KeyVis,

We’ve not heard back from you in a while. I’ve marked this as the possible solution to the problem. If you’re still having the issue can you please let us know and we’ll look into it further.

Thank you!


Hi there,

I actually resolved it by installing onto one of my other towers but I am sure the issue could be resolved by using the CMD prompt. However unfortunately I don’t know how to do it. I have placed the installer onto the Desktop…what do I have to type into the Root in CMD to get it to install?

At the moment I have ‘C:\Windows\system32>’

what else do I have to type to get the CMD to install the installer (UnrealEngineInstaller-1.9.2-2361519) to install it?


So without knowing your folder setup, I’m making some assumptions that you have have a pretty typical setup.

Something like this should work for you if you want to run the installer on your desktop from the commandline.

  1. Start a cmd prompt as administrator
  2. Make sure the command prompt says ‘Administrator’ in the title bar
  3. Enter the following command into the command prompt

msiexec /i %Homepath%\desktop\UnrealEngineInstaller-1.9.2-2361519.msi

Hi there,

Thank you for helping, I have tried what you recommended which works but brought me to this;


That is a message from msiexec telling us that the commandline was not entered correctly or that the installer was not found at the path we specified.

Without knowing more about your setup and the full installer path I can only make guesses at the issue:

  1. Make sure you entered the commandline exactly. msiexec /i %Homepath%\desktop\UnrealEngineInstaller-1.9.2-2361519.msi
  2. Make sure that your installer is on the desktop.
  3. Make sure the installer is named this UnrealEngineInstaller-1.9.2-2361519. If not, adjust the installer name you enter in the commandline to match the one that is on your desktop. Be sure to leave the .msi extension on it.
  4. Make sure %Homepath%\desktop points to your desktop directory where the installer is. If it does not, replace %Homepath%\desktop in the cmdline with the path to your installer.


Thanks again but I am not getting anywhere I am afraid. It is simply on the desktop, I have screen grabbed the installer on the desktop along with the CMD. But to the same result unfortunately.

ok the Jpeg isnt working now…


I have attached a screen grab of the installer on my desktop and the CMD line but to the same result. It is simply on the desktop, what else would you need to know?

Can you try replacing %Homepath%\desktop with your desktop path?

Halfway down this page are super simple instructions to add “Run MSI as administrator from Command Prompt”.

This is by far the easiest workaround.

I’m still running Windows 7 Ultimate 64bit and ran smack into this problem. I have made several security restrictions to my security policies but nothing extravagant. Just downloaded EpicInstaller-9.11.2-unrealengine and as I said, had the missing DLL issue. the link the fella posted How To Run MSI File As Administrator From Command Prompt In Windows worked in part, the command prompt failed but downloading the registry key worked great (and yes i scanned the key with antivirus, confirmed it with non-windows raw text editor, and no virus or malicious effect).

This is clearly the easiest solution, but it works, in case someone else hits this thread after 5/2/2019.