DLL issues when trying to install


I have just bought UE4 to get my head round it, when I try to install it there comes a message saing a DLL is required for this install to complete. Now reading other posts on here there have been a couple of suggestions including running it through CMD with admin rights but I don’t exactly know how to achieve that so any help would be greatly appreciated in getting this resolved.

yes its for the launcher, I run windows 8 will that be any different?

If this is for the launcher msi then most people find that the following works:-

msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt

You should place the msi on C:\ and rename as in the line above.

Running cmd as admin, on windows 7, you can hit start, type cmd, and right click on the result to select “Run as administrator”.

Windows 8 there are loads of ways too:-

Hope that helps!

should be pretty similar. Let me know :slight_smile:

Assuming you have placed the msi on the root of C:\ and named it UnrealEngineInstaller.msi then it should help. If it does not, you can post the UnrealEngineInstallerLog.txt file that appears next to it here and we can help some more

so just type “msiexec /i C:\UnrealEngineInstaller.msi /L*V C:\UnrealEngineInstallerLog.txt” into the CMD thing and it should do something right?

link text
not currently working for me at the moment with that

Ahh it looks like this is a different error to what i expected. Could you upload a screenshot of the error message?

OK thanks for the info. I’m not sure if this will be quite a quick fix yet. Some people don’t run the msiexec from cmd and instead just from the windows run box (WindowsKey+R) so you could try that, but we’ll get back to you if we find an answer! Sorry for the problems.

This is what I get

I have tried that and still doesn’t work. I hope you find a potential solution as quickly as possible.

We’ll do our best :). Just to double-check, the cmd that you ran was definitely ran as administrator? Here’s a bunch of other instructions on how to do that if you weren’t sure. You should see the words “Administrator” on the title bar of the cmd windows:-

I think that may have worked, if it does I might be feeling a little sheepish for forgetting that.

Great news :slight_smile:

This issue is probably being caused by the fact that your user and/or group lack some required permissions on the temp folder the installer extracts to. This folder can usually be found here: c:\Users\{YOUR_USER_NAME}\AppData\Local\Temp

In your case, I would guess you have permission settings that are preventing the installer from executing from that folder. Can you check to see if your user has ‘Full Control’ of the folder below? If you don’t mind sharing, it would be really helpful for us to know what your security settings are for this folder before you make any changes.


If you find none of your groups/users have Full Control you could try a few things:

First, as Leigh mentioned, you can run the installer from a command prompt that has been elevated. The one bit of info that is missing from Leigh’s description of the fix is that you need to select Run as Administrator when starting the command prompt.

An alternative fix is to just modify the folder permission settings so your user/group has Full Control. I hope you try this and report back because we have had a hard time tracking down the root cause of this issue. You can do this by right clicking the folder and selecting properties. The Security tab should show you who has access to the folder and what they can do with the contents. For example, if I wanted to fix something like this locally I could give the ‘Users’ group Full Control of the temp folder on my machine.

Ya, good to know that this worked for you. Would you mind telling us a bit about the security settings of the following folder(as mentioned in my answer)? A screenshot, or any info, would help a lot in pinpointing the root cause of this issue.