Distance fields AO giving artifacts on interiors?

I’ve been testing Distance fields on my project and it gives me decent results on everything but interiors, I get these wierd artifacts, that only seems to come on the inside of buildings.

The houses are all made in kit form so it should be able to and looks like it is able to make quite good Mesh distance fields but for some reason i still get artifacts that seem to be coming from the Distance field ambient occlusion.

I can’t seem to find any control for blurring it out in some way. The only controls i can seem to find for the AO is under the Skylight and i can’t seem to make it appear nice on the inside without it completely removing it from the outside. .

Distancefields AO visualized

On the above image I’ve turned off [Affect distance field lighting]
And the effect is still visible. Here are the same room with affect distance field lighting turned on.

I don’t know what i’m doing wrong? is there a way to fix it? should i just go back to no Distance fields?
If i need to provide anything else i’ll be happy to!

Mesh Distance fields

With min occlusion on 1 the AO is turned off and the artifacts disappear but the overall image losses a lot of “grounding”

Are you able to set this stuff with blueprints? You may be able to turn off DFAO through a volume trigger as you enter the building.

I honestly have never seen this happen with DFAO before, so I can’t provide much assistance in this regard. You may be encountering an engine limitation in which case you may have to switch back.

I also noticed in your side-by-side of the AO min occlusion being set to 1 that everything simply becomes brighter rather than changing the shape of the AO-- you may be able to compensate by simply turning the brightness down on your interior lighting/materials (though it’s a poor man’s way of doing it, it’ll do the job).

I’ve noticed that lowering the Occlusion Max Distance seems remove a lot of the artifacts which seems kinda opposite to me? since i would expect lower quality results? And the recommended value is 1000. It seems to me that the higher the value the more overlapping occurs creating the artifacts, but below 100 the artifacts become more prevalent again.

Half the recommended size

1/10 the recommended size

having to lower the max distance seems to effect the overall lighting making it lighter overall.

1/10 of the recommended size

Half of the recommended size

But so far it seems to be the best solution. i still get some artifacts but they seem much more minor now.

I solved with the console command r.AOObjectDistanceField 0

1 Like