Dissapearing meshes from maya to UE4 after deleting faces

Hi guys,

Basically I’m having an issue with the export from maya/import to UE4. The main issue stems from the character I have (rigged and weight painted with A.R.T.).

When I add clothes I need to delete faces from the main mesh so that there aren’t any clipping issues with the existing animations, However whenever I delete faces from the body mesh in Maya 14 to accommodate for the new trousers, the body mesh disappears when I export it from Maya/import it into UE4. The separate trouser mesh remains, as does the skeleton structure itself and I cant figure out what’s causing it.

I’ve tried checking the normals and the skin weights and they’re all fine, I’ve also tried combining the meshes into one and that doesn’t fix it , the mesh exports perfectly when I don’t delete the faces from the legs. Has anyone else encountered this? and has anyone found a solution?

Any help would be appreciated

I’m having the same problem. It works in 3dsMax if you keep the skin modifier at the top and delete faces in the “edit poly” beneath. However I need to be exporting it from Maya. Hope someone answers.

Having the same issue in Maya LT 2016. Deleting faces causes the whole mesh to disappear, same with using Mesh->Separate

Hm. Looks like the issue might lie with Maya LT. Re-importing the mesh back into Maya yields the same results.

edit: There was an export error that causes the mesh to not be exported. Deleting the Non-Deformer History fixed this for deleting faces, however mesh separate cannot be fixed in this manner.