Download

Displaying bones when playing?

Hi,

I am setting up a IK structure for my character and would like do display the bones when I run the game in the editor.
So that I can ‘Eject’ and move my ik controllers around to see how the bones move to figure out what I am doing wrong.

Is there a good way of doing this? I tried ‘showDebug bones’ but that doesn’t display the bones of my character.

Cheers
Fred

Take a look at this thread: How to use 'ShowDebug Bones' in the editor? - UE4 AnswerHub :slight_smile:

“That command is used for when you are in Play-in-Editor mode or Standalone mode. When you are playing bring up the Command Console by hitting the tilda key ~. Then type ShowDebug Bones.”

Hi and thanks. Unfortunately as I mentioned I tried the ‘ShowDebug Bones’ but it does not display anything that I can see. I also tried toggling on wire frame at the same time (which works fine).
Could it be because the character is not ‘me’? It is a separate ‘Character’ blueprint . Is it because that entity is not ‘possessed’?

look in Persona (just dbl click your char in content browser) and show bones there.(top of viewport)
skeleton may be scaled too small to see, which may lead to other issues altogether later

Yes I can see the bones fine in the editor. Its just that I want to see them as I am playing so that I can figure out problems with my IK rig.

I havent tested this command, but it could be that this is the case -> just test it :slight_smile:

hello
I have the same problem , did you find the reason why the "Showdebug bones " command do not work ?
or a solution to show the bones in the play mode ?
please i have to resolve this problem , i have done a lot of research in the internet but i did not find the solution
thank you for your help

hi again, did you make this character yourself? what program did you make it in?

this command works fine usually (did for me - tested it), but you can’t hit F8 & break out of it.

hi
I use the HeroTPP.FBX character from the tutorial of unreal engine
and ‘’ FABRIK " an inverse kenimatic method already existed in unreal engine

press the tilda key, ‘Show Bones’