Download

Displacement not working (well)

Hi, all,I’m having some problems setting displacement material for landscape.

After several trials on displacement for landscapes fails, I start to verify the problem on a simple box
(The enable tessellation is ticked, the method is PN triangle)

So this is my material at first. Learned from this tutorial
https://youtube.com/watch?v=iadBjWDlOnU

qmt1.JPG
Of course it fails
qr1.jpg
Then I find a post, which is telling me to do this…And it works (even when enable crack xxxxx option is ticked)
However, its displacement result is very sharp and not smooth. It is on a UE4 box.
No matter how much I put in tesselation multiplier, even 100, its still not adding enough triangles to the surface. What’s more, the material preview shows a black ball, and it is flickering between this result and correct shading result
qr2.jpg

It’s not until I’ve imported a plane from 3DSMAX with an exisiting 6x6 subdivision then I get this following smoother result
qr3.jpg

However, this is far from the effect in Quixel Mixer

qm1.JPG

Does anyone know how to achieve the correct result in the final image?

Disable “Crack Free Displacement” and make sure your base mesh already has a good tessellation.

Hi Raildex, thanks for the help.
I was about the correct my post that I’ve unchecked the “Crack Free”…
So In unreal, if I want to get good tessellation result, I still need to have an already subdivided mesh to perform smooth displacement?

You indeed need an already well tessellated mesh.
Unreal performs Tessellation up to 8 levels. everything above that would slow down or cost too much.
(Think of Tessellation to add small details)

Thanks a lot! That is caused by my limited subdivision level.