Displacement Map Does not Appear to Work

Hello, so I had some questions about landscape materials. I’m actually trying to use some of Megascans surface materials on my terrain generated from World Machine. However, as of right now, it is not reflecting the displacement maps that I connect to the MakeMaterialAttributes node. I see no difference in the material preview or any tessellation whatsoever after applying the change. I am connecting the displacement map into WorldDisplacement. I can’t see any other options for displacement maps. I actually made the two materials using material functions if that makes any difference.

I don’t have any screenshots at the moment as I am away from my PC.

Plug the displacement map is not enough. Also you would use its value to drive a lerp’s alpha and at pin A you would set a negative number (make the surface sink) while pin B a positive value. These values you should set accordingly with your materials when they were made in substance.
Clicking on the Material empty space, you will see the panel at left with the material properties, move to the bottom and you will see the options for Tesselation appear, once you set there, the pin at the material output called Tesselation Multiplier will show up. You need to set Tesselation Multiplier pin with a value: start at 1 for now.

[FONT=“Helvetica”]Hey thanks for the tips! I found the tessellation options and was able to activate displacement in my landscape material. However, what if you made material functions that you used in your landscape material? I made 2 material functions and they are plugged into a layer blend node. Within the material functions, I tried clicking on the MakeMaterialAttribute node to see if it would display options for tessellation, but it didn’t. Do I need to use just regular materials instead of material functions? Or would activating displacement in my landscape material also displace the material functions?

The common practice is to put MakeMaterialAttribute outside the material functions. There are several material functions in the engine and samples from Epic that they do exactly like this. This happens because the pins will only show in the material editor which currently edits a material with tesselation set.

If you think your code is getting too poluted you can always “hid” some portions collapsing few nodes into a single one. In this case they are still in the same material, but easys a lot the visualization.