Disabling walk on character not working

I only want my character to use the “flying” movement mode. So in the options for the character, I unticked all movement capabilities besides fly. But the character still uses walking controls when “on ground” as if nothing changed.

(I’m currently using an older version of the Engine. Let me know if that’s the problem.)

I got it. Also in the character’s settings, I had to set “default movement mode” for on ground to flying.