Disabling texture streaming prevents them from loading at all

Hi there,

I got some problems with the texture streaming, sometimes they don’t load correctly and are extremely blurry instead (I already set the distance multipliers of the meshes manually to very high numbers).

In project settings/rendering there is an option ‘Texture Streaming’. But if I disable it (as suggested here) they are not loaded at all which is the exact opposite what you would expect (asked 2 times if this is correct but didn’t get a reaction).

Sorry for asking this again, but then I’ve to asume that this is just a bug?

Thank you,

Hey ,

I am having a difficult time reproducing the issue you are reporting. If you have a couple of textures I can test, as well as the texture settings you are applying for these texutres, that would help me reproduce the issue on my end.

I looked over the post you linked and I saw you attempted to use the construction script as well as the command line. If you are able to reproduce this issue strictly using the ‘Never Stream’ option within the texture settings that would be the optimal test case.

Thank you,

Hi Andrew,

hmm, ok. But I’ve difficulties to understand the difference between setting each and every texture to “never stream” and using the option inside the project settings. The strange thing is, that UE4 doesn’t just load all textures referenced from the current map, but essentially none at all. Can you confirm, that this is an intended behavior?

Hey ,

The behavior you are experiencing is expected, and there are a lot of reasons as to why some of your textures are blurry or do not show up. The best way to gain a better understanding of how Texture Streaming works is to have a read over our detailed documentation. It will go over ways to optimize and debug your textures so they work correctly. There is a set memory pool for your textures as well as other factors that will affect how they appear, especially if you have the ‘Never Stream’ option enabled.

Texture Streaming

This documentation should provide you with enough information to answer any further questions you might have as well. There is a lot of helpful console commands that you can use to figure out how to optimize your textures when streaming is disabled.

Cheers,

Ok, thank you. I’ll try my best. It’s really strange becauses sometimes a texture just doesn’t show up, no matter how long I wait. The next time it’s instantly there…

It has a lot to do with all the variables taken into account based on things like asset type, texture size, and texture group, as well as location within the map. If you are forcing all of your textures to never stream and you have a lot of high resolution textures, they are all being saved in memory and their priority varies depending on these variables.