Download

Disabling Spatialization Breaks Attenuation

Hey all,

Wondering if I’m doing something wrong. I’ve got some looping ambiance sounds that I placed in my level and I want them to be attenuated so they are limited to playing in a specific area, but I want to disable spatialization so that it doesn’t sound like the audio is coming from a specific location. I thought it would be as simple as turning off Spatialization on the ambient sound actor, but this seems to break attenuation and make the audio play everywhere (at least in PIE).

How can I get attenuated, non-spatialized audio in the engine?

Oh, never mind I figured it out. For whatever reason using the Spatialization checkbox on the Ambient Sound actor doesn’t work, but if you disable Spatialization in your attenuation file, it works. So leave Spatialization checked on the Ambient Sound Actor at all times I guess.