Download

Disabling crouch moves character down problem

Hi, I’ve got a problem. I want to turn off the moving character down property of the crouch. But I can’t turn off it, because the checkbox is grey. What I need to do to turn off this property?

http://puu.sh/bfH3N/db5085b8fc.png

eh, I think that check box is already off isn’t it?
maybe it’s tie to walk off ledge check box, try turn it on and see what happen.

Nothing happens when I do it. Anyways it isn’t off, because when I crouch, the mesh goes under the ground.

unfortunately it appears that it was turned on automatically when walking, you need to turn it off like this.
(you can also move set to false part before you change character to crouching mode.)

disableCrouchMoveDownFlag.png

It doesn’t work. It goes under the ground.

http://puu.sh/bgGNP/ed1bb5440b.jpg

LOL, sorry, I never really used CharacterMovement crouch until now.
So basically the move character down only moves the capsule, but interesting part is your mesh’s pivot has to be on the feet.
(you can turn off hidden in game check box for root capsule and see it changes in game)
If you check regular third person template, go to components, select mesh, you’ll see a -95.0 in Z, which means the pivot of input mesh is at feet not at hip.

After you set this up like in the third person template, you don’t need to mess around with that flag anymore. :slight_smile:
There are some hard coded stuff there when I test with third person crouching with this flag and the result is hilarious.
Guess someone hacked this stuff up really quick and didn’t expect people to mess around with it much. :wink:

So if you don’t know this beforehand you’re doomed to re-rig your character/s? I refuse to beleive it could be this bad. There must be some solution to this issue.

pretty much I guess. I never really thought of have a character rig with root pivot on hip( that was for say rag doll, and mesh pivot/skeleton pivot are different things anyway ), you kinda always have a pivot on top of everything that’s at feet so it makes easier placement.
For amusement, when I actually turn the CroundMoveCharacterDown flag off, character movement move my entire character mid air, it shrinks capsule size to 45, still center pivot, and state changed into falling right after I press crouching.
So there must be a hard coded offset for the mesh when crouch or any other movement that changes capsule pivot location so the feet pivot of mesh always in contact with bottom of capsule with settings on crouch half height value.

or you don’t use the crouch function from CharacterMovement, that should be doable.(animation part is easy, and you can use a different capsule for hit detection while original capsule are disabled)
In fact a lot people have answerhub question to get crouch to have smoother transition.

My version of the fix

My version of the fix. Maybe someone else needs.