Disabling a Sound Device causes Editor to freeze

UE4 Version: Launcher Download
OS: Windows 10 (64bit)

Description: When changing or disabling the default sound device the Editor freezes in place, rendering you unable to save anything.
Reproduction Steps:

  1. Open any project that has sound assets
  2. Disable sound device
  3. Try to bring back Unreal Engine into focus, failing to do so since it is frozen

Hey Xaymar,

I just tested this on two different machines (Win 7 & Win 10) and did not get the same results as you are reporting.

Could you provide me with your ‘dxdiag’ so I can take a look at your systems specs?

I will say, I did notice that when you disable the ‘Default Sound Device’, you need to restart the editor/project to be able to hear sounds again.

Thank you,

Hey Andrew,

I’ve actually reported it wrong. While it looked like the editor kept freezing after disabling a sound device, what was actually happening is that the ShaderCompileWorkers all got stuck on a Material-asset corruption.
I’m not entirely sure how the material got corrupted, but I’ve been able to fix it.

I’ll close this as invalid, if you created any internal tickets for this you can do the same.

  • Xaymar