Disable Tonemapper?

Hi! In 4.26, I can turn it off with r.TonemapperFilm = 0 and use settings such as Crush Shadows, Crush Highlights e.t.c. There is no such command in the new version. How do I switch to alternative film settings? Thank you in advance.

Any solution to this? r.TonemapperFilm 0 seems to do nothing in UE5.


r.TonemapperFilm 0 was the only way to get rid of the heinously distorted colors in UE4 and seems to have been intentionally removed from UE5.

I understand that there’s probably some theoretical and sound reason for pushing the current iteration of Unreal’s tonemapper, but the default setup is pretty hellish to work with if you just want to drag in textures and have them look the same as they do in whatever software you’ve authored them in.

I’d really love to be able to have true colors in my project without editing the source code. Can we just have this flag back?

Change line 659 of PostProcessTonemap.usf from:

half3 OutDeviceColor = ColorLookupTable(LinearColor);


half3 OutDeviceColor = LinearColor.rgb;

Placing an unbound PostProcessVolume and setting Tone Curve Amount under Misc to 0 did the trick for me. However I don’t think it disables the tonemapper but it gets the colours of my textures closer to what I’m seeing in Blender.

1 Like