Disable the mouse input during a cut scene

Hi guys I’m new to UE4. So I have made a cut scene in my first person level. I found that when the cut scene is played, the character’s movement is automatically disabled by default settings, but I can still control my mouse, I can click my mouse to fire the gun during the cut scene. I managed to disable the mouse input whenever the cut scene is played with disable nodes in blueprints, but both the character’s movement and mouse input remain disabled when the cut scene is over, my character gets stuck there after the matinee. Is there anyway to enable them once the matinee is finished playing?
Someone mentioned using Bool to control the input, but I figured that is more for in game control, I’m just looking for a proper way for just matinee.
Here is my BP, can someone help me out? Thank you!

Try with something like this:

For get the “MatineeActor” node, just select it in the editor, go in the blueprint, right click, and then click on “Create a matinee controller for xxx”.

That works! It was just this easy! Thank you so much!

No problem, mate. Could you mark this as answer, please?