Disable smoothing in Unreal?

What is Normals set to in import dialog window? Set it to Import tangents and normals if it is set to Calculate and see if it helps.

1 Like

Hey there,

I’m trying to import a character model I made using Blender into Unreal Engine. In Blender, the mesh is not being
smoothed, because it is supposed to actively “look” low-poly.

When being imported into UE4, the mesh appears smoothed, with a look similar to the one
rendered by Blender when the shading mode is set to “Smooth” instead of “Flat”.

The problem apparently only occurs when dealing with Skeleton Meshes, I never had any problems
when importing Static Meshes.

Is there a way to disable this effect? Or is there any box I should have checked or unchecked?

The export seems fine, importing the mesh into other 3D software works flawlessly.

I attached two screenshots that show the same mesh in Blender and Unreal Editor.

Thanks a lot for any answers

MrPhil

Blender:

http://s7.directupload.net/images/140805/slslt4ji.jpg

Unreal:

http://s7.directupload.net/images/140805/fnivpqbv.jpg

Thanks a lot - that works perfectly!
:slight_smile:

For me nothing work, tried every combination and every time the character is smoothed, this is driving me crazy from 2 days in a row without luck.

My model only has morph targets, no bones, but I need to import as skeletal mesh to use the animations. When imported as static mesh it works, well without the anoying auto-smooth.

ver 4.10.2

Found something, the problem become interesting, when the morphing value is 0 my character look non-smoothed as i want.

When i change the morph target value the smoothing start to appears, see the following two images:

Which program are you exporting from and what are your export settings?