Download

Disable shader compilation on dedicated server?

For my dedicated server build, I strip out a lot of the texture cache files (as the server doesn’t need these).

However, whenever I run the server, it always tries to compile a few of the base materials. These ones to be specific:



[0010.11] Log: Incomplete cached shader map for material DefaultMaterial, quality 0, compiling.
[0011.99] Log: Incomplete cached shader map for material M_FX_BloodDecal_FadeViaDissolving, quality 0, compiling.
[0012.15] Log: Incomplete cached shader map for material M_FX_DecalParent_Simple_Multiply, quality 0, compiling.
[0012.30] Log: Incomplete cached shader map for material LevelColorationLitMaterial, quality 0, compiling.
[0012.91] Log: Incomplete cached shader map for material LevelColorationUnlitMaterial, quality 0, compiling.
[0013.17] Log: Incomplete cached shader map for material LightmapResolutionMaterial, quality 0, compiling.
[0013.96] Log: Incomplete cached shader map for material MAT_LevelColorationLitLightmapUVs, quality 0, compiling.
[0014.70] Log: Incomplete cached shader map for material MaterialError_Mat, quality 0, compiling.
[0015.35] Log: Incomplete cached shader map for material ShadedLevelColorationLitMaterial, quality 0, compiling.
[0015.95] Log: Incomplete cached shader map for material ShadedLevelColorationUnlitMaterial, quality 0, compiling.
[0016.15] Log: Incomplete cached shader map for material TerrainCollisionMaterial, quality 0, compiling.
[0016.46] Log: Incomplete cached shader map for material WireframeMaterial, quality 0, compiling.
[0016.67] Log: Incomplete cached shader map for material DefaultDecalMaterial, quality 0, compiling.


Is there anyway I can disable this compilation? I’m not sure why the engine is trying to compile shaders when running as a dedicated server anyway.

Hello @Coldscooter, did you ever figure this out? I will also need to create a dedicated server later and this is one of my concerns.
Any info about how you addressed this (or eventually address this) is appreciated.

Turns out you only need to include LocalShaderCache-PC-D3D-SM3.upk (which gets generated the first time you run the game as a client). This prevents the ded server recompiling those base materials each time it runs.

The other texture files and shader caches can be removed:



\UDKGame\CookedPC\CharTextures.tfc"
\UDKGame\CookedPC\Textures.tfc"
\UDKGame\CookedPC\RefShaderCache-PC-OpenGL.upk"
\UDKGame\CookedPC\RefShaderCache-PC-D3D-SM5.upk"
\UDKGame\CookedPC\GlobalShaderCache-PC-OpenGL.bin"
\UDKGame\CookedPC\GlobalShaderCache-PC-D3D-SM3.bin"
\UDKGame\CookedPC\GlobalShaderCache-PC-D3D-SM5.bin"