Download

disable reflection from a light

Hello,

It would be very useful if there was a checkbox in spotlight / pointlight actors, that would enable or disable the light’s reflection of glossy surfaces. I have experience with vray renderer and this was a very useful feature.

Thank you.

every light has a “min. Roughness” Parameter that exactly does that.
Unbenannt.jpg
Unbenannt.jpg

Thank you for your reply Raildex_.
Your solution works only in certain situations, when the environment actors around the light have non-reflective materials on them. When there are assets which are more reflective, the roughness of the light, just diffuses the reflection across the surface of the objects, thus making them washed out.

Here is what I mean:
I have a mirror placed in the scene and you can see clearly how the reflection washes out the reflection of the mirror (also it has effect on other actors that are reflective, but not to that extent)

bd43fddb09e5abc73ca088061a0ec86f235384e7.jpeg
bbeef397b3b75d994d181b272fe54a36a58d53c7.jpeg

So setting the roughness to 1 is viable temporary hack, but it certainly does not substitute an option that would allow us to disable the reflection of a light source.

Have you tried turning your mirror to unlit? This way it does not receive any lighting.
Not sure if this helps though.

i found setting the light radius to 50 and min roughness to 0.018 exactly causes the specular to completely disappear.
if you lower to min roughness to a value nearer to zero it causes what looks like NaN errors.

If I set it to unlit, then I won’t be able to make the material reflective :slight_smile:

I tried this, but it doesn’t work for me, the light is still visible in the reflection of other objects.

is there any solution to this?

Just wanted to add my 2 cents… Using 4.22 there isn’t an option for min roughness anymore but there is a value called Soft Source Radius which seems to do the same thing as suggested above.
It worked really well in my case as I didn’t want to remove the reflection entirely, just make it less sharp.

Just set Specular Scale 0.0 for the light that you want (in details rollout Light)

Thanks @Nickshiv
This worked perfectly.

geez I wish i read your post earlier. I found it and was going to post it and find your post lol.
man, this Unreal isn’t precisely the most intuitive software around huh…