Download

Disable mouse in Set Input Mode UIOnly

I’m looking for the checkbox that allows me to disable mouse in the UIOnly Input Mode, but I can’t seem to find it.

The game I’m making is only for controller and keyboard so the mouse cursor or inputs are not desired in any of the menus.

Thank you!

You have to uncheck the context sensitive tick box then type ‘Set Show Mouse Cursor’

I tried it. It’s still visible.

Did you assign a PlayerController to the node?

Indeed I did, as you can see here:

Yes I see, the only thing I can think of is that is being set to true somewhere else? Maybe in the widget which pops up. To test this, you could put a delay before the set show mouse in your BP_Player, set it to 2 seconds, then if you open this widget, then after two seconds the mouse disapears, something else is setting it to true.

Then you just have to find that.

Thanks for the suggestion. Tested that out, with no luck. :confused:

This is an *older *bug.

As soon as the player controller loses focus, it’s the widgets’ (if there are any) job to control cursor’s visibility. Check out this AH thread for more info and a couple of workarounds:

https://answers.unrealengine.com/questions/727143/cant-hide-mouse-cursor-again.html