Disable message log automatically opening

New in 4.21 when you close play window it opens up the message log. How do I disable this so I can remain on the blueprint I’m working on?

2 Likes

Please answer this question.

This started happening to me also, I looked in the editor options but did not see any where to turn it off.

Did anyone figure this out?

Did you get this figured out?

Any update on this? It’s so annoying! Every time I press build, it pops up to tell me lighting needs to be rebuilt. Like yeah, that’s why I’m building! :confused:

Mine no longer pops up. It just stopped one day. But I think what happened is I keep fixing any issue that is RED and now there are only warnings so it does not pop up. If I am playing and then exit it will still pop up if there is a RED critical error but if it is a Yellow warning it does not pop up.

Mine no longer pops up. It just stopped one day. But I think what happened is I keep fixing any issue that is RED and now there are only warnings so it does not pop up. If I am playing and then exit it will still pop up if there is a RED critical error but if it is a Yellow warning it does not pop up.

It’s back…Why is the message log popping up when ever I close the play View Port…argggg

Any luck solving this? It’s annoying me to no end.

Only way I could find to resolve is fixing what is causing the error messages.

Thanks for reply. Unfortunately, in my situation, there are no errors… the window just pops up anyway. EVERY. SINGLE. TIME.

There is an option in the editor preferences to open new windows in same window. What I do is keep the message log tab open in the main window as the first tab and do not close it. If there are no error it will not open because it is already open as a tab :slight_smile: May not be perfect but it keeps me from having to close it a hundred times. Hope it helps.

2 Likes

You aren’t going to stop it from popping up, but you can just move the Message tab to the editor, I put mine underneath world settings, that way it doesn’t pop up and cover the screen while you are working.

2 Likes

My godness thank you :,)

And What About The Dam Little Ones That Show Up And DON’T Go Away On The Right, Lazy UE Developers, Too Focused On None Sense And TV Shows To Understand The Concept Of Ease Of Use For Actual Game Devs, UE Should ONLY Be For Gaming, ONLY, EVER!

1 Like

Yeah, it blows.

Same here, keep saying “has to have Simulate Physics enabled if you’d like to GetMass”

Indeed I do GetMass but I don’t need to simulate physics at all.

It Keeps popping up the Message Box while everything works and it’s boring !