Disable Ledge Movement Smoothing

Ok the title might not be grammatically correct, but let me explain. Basically, when you walk over something e.g. a block, instead of immediately going on it, there is a weird transition happening that makes the character float in the air. I will demonstrate what I mean with a drawing real quick.

The black circles are totally fine and what I want, but that ugly dumb grey one in the middle is not what I want. I want the character to be on the ground floor without such a dumb transition.

I have already looked into the “Perch” section in the movement component, but no matter what settings I make, it will never completely remove that transition.

Any ideas/help? :confused: