Download

Disable launcher?

Can we somehow disable the launcher? It always show up even when we open the editor directly. Pretty annoying, especially when you go back and forth between UEditor and VSC++.

You can just close it after you are in the engine, then it won’t show up anymore, otherwise I think there is no way how you could disable it

You often have to restart the editor after compiling the c++ code and the launcher is started every time. It would be good if it could be disabled.

Here you can find some official statements about that topic: Prevent the editor from launching the launcher? - UE4 AnswerHub :wink:

You can simply comment this in Editor.cpp / void UEditorEngine::InitEditor(IEngineLoop* InEngineLoop):


    if( !FEngineBuildSettings::IsInternalBuild() &&
		!FEngineBuildSettings::IsPerforceBuild() && 
		!GIsBenchmarking &&
		!GIsDemoMode && 
		!IsRunningCommandlet() &&
		!FPlatformProcess::IsApplicationRunning(TEXT("UnrealEngineLauncher") ) &&
		!FPlatformProcess::IsApplicationRunning(TEXT("Unreal Engine Launcher") ) )
    {
        IDesktopPlatform* DesktopPlatform = FDesktopPlatformModule::Get();
        if( DesktopPlatform != NULL )
        {
            DesktopPlatform->OpenLauncher( false, TEXT("") );
        }
    }

And then recompile the engine.

Hey all, I’ve added a pull request for an option in Editor Preferences to disable loading the launcher on startup. Add your voice here if you want it:

https://github.com/EpicGames/UnrealEngine/pull/1427

nice work!

I actually love the Launcher, but it’s pretty useless if you don’t use the Launcher version of the engine. If you’re on the github release like so many of us, it’s just annoying to have to close it out every time the editor restarts.

I’d love it if the Launcher worked as kind of a github client… pulling the latest updates straight from Epic’s repo to my local directory with a single button press so I didn’t have to mess at all with the git shell.

The binary version of the engine just doesn’t cut it, as far as features go.

X:\Program Files (x86)\Epic Games\4.12\Engine\Build …Create “PerforceBuild.txt”. This is the solution to this problem.

Disable Launcher

X:\Program Files (x86)\Epic Games\4.12\Engine\Build …Create “PerforceBuild.txt”. This is the solution to this problem.