'Disable input' not working in mobile previewer

Hey all,

I have a top down game that navigates the player using the touch screen. When I have the camera pan over to a different location to show that an area of the level has changed, I want to disable all input so the player doesn’t move.

So in the level blueprint, when the player flips a switch and the camera moves away, it runs through a disable input, and when it comes back, it fires off to an enable input.

Problem is, when I am in the editor, or playing in the mobile preview, it doesn’t work. I can still click around the level and the camera will freak out. Is there something I am doing wrong?

Thought I’d bump this.