Disable gravity on characters?

This is probably really stupid, but I have no idea what’s happening.
I’m creating a grid-based game, and I’ve created my own system for calculating and applying gravity. I’ve turned off every single possible gravity-related thing on my character, but for some reason, he’s still affected.


Is there any way to make a character without a collision mesh, or disable gravity and have it work?

Character Movement Component → General Settings → Gravity Scale

1 Like

Thank you!

Leaving this for anyone else that comes looking for answers:

Depending on how you’re defying gravity, Character Movement Component -> Character Movement: Flying -> Braking Deceleration Flying may also bite you on this, even with gravity disabled and the scale set to 0.

The solution in my case was to set this equal to Max Fly Speed.

1 Like