Disable/Enable Axis Input

So I have a character that has both third person and top down camera views. And when I press a button the cameras are switched. My only problem is that I can’t get the Axis mappings to completely turn off/on when the camera views switch. I’ve tried Booleans, but since the axis is updated every tick, it checks the Boolean every tick and it causes the camera to be all glitchy and character movement gets thrown off. I then tried Set Actor Enable Tick to false, but that doesn’t stop the axis input from firing. Is there another way I can do this?

Here’s an image of the blueprint and the camera settings

I realized that the axis inputs weren’t actually affecting anything and it was my movement. So I fixed that and it’s all good now.