"disable DPI-scaling suddenly" enabled for all ue4's

4k monitor > open ue4. (using 4.11 atm, might happen on other versions)

Play in New window > r.setres 3840x2160f
doesnt work
Play as stand alone game > r.setres 1920x1080f
Play as stand alone game > r.setres 3840x1080f
works… but!
DPI scaling of all ue4’s mess up.

I’ve had this issue with UE4 for over a year now. This is combined with an issue about incorrectly reporting my screen resolution. With DPI scaling ON, I get my resolution / DPI Scaling reported from GameUserSettings. If I switch it off I get the correct resolution. It also resets on the UE4Editor.exe setting if I change resolution at all. Next time I run editor it will be tiny with no scaling.
There is a DPI aware setting on newer versions of UE (4.15+) that you can set on the shortcut to your editor. UE4Editor.exe -enablehighdpi

Currently no clue what happened, how it happened, and if its either ue4 or win10. (wouldnt be surprised if its the latter because its a massive bleepbleepbleep)
was working in 4.11, had to record a video at 4k resolution.
playing as standalone, set to r.setres 3840x2160 f, didnt work a few times.
Rebooted ue4 4.11 suddenly ^ that did work.

Closed ue4 again, opened ue4 again, everything was extremely small. (UI/FONTS)
Widget scaling was still at 1.0 and changing it gave very distorted effects.

spend about an hour+ trying to fix it.
cleaned cache, deleted saved/intermediate/whatever folder i could think of, moved to new project, etc, etc.

Suddenly noticed that the 4.11 editor.exe had “Disable display scaling on high DPI settings” enabled in the compatibility settings. (rightclick on .exe > com. sett. > Disable display scaling…)
noticed all ue4 versions suddenly had this checkbox enabled.

Had to disable “Disable display scaling on high DPI settings” on all my installed ue4 versions. (4.11 up to 4.16)
no clue what happened, and why.